Dopad chyby je tak obrovský, protože OpenSSL patří k nejrozšířenějšímu kryptovacímu softwaru na internetu. Bezpečnostní experti z různých koutů světa proto nyní testují jeden server po druhém a zjišťují, kterých uživatelů se tedy zranitelnost mohla týkat. Seznam je k nahlédnutí zde.

ČTĚTE TAKÉ:
Šifrovací knihovna OpenSSL má závažnou bezpečnostní chybu
Změňte hesla, vyzývají experti kvůli Chybě krvácejícího srdce

Z testů je patrné, že trhlina se týkala i velkých portálů, jako jsou například Yahoo.com, Flickr.com či Mail.com. Zda opravdu někdo chyby na těchto konkrétních serverech využil a data odposlechl, však zatím není jasné.

Experti však již dříve upozornili na to, že útočníci mohou disponovat přihlašovacími uživatelskými údaji, a to včetně soukromých hesel k e-mailům, sociálním sítím, on-line bankovnictví nebo nejrůznějším internetovým obchodům. Vzhledem k tomu, že je řada účtů navázána na platební karty, je hrozba nebezpečí o to závažnější.

Uživatelé by proto podle nich měli z preventivních důvodů změnit na serverech, kterých se zranitelnost dotkla, svá hesla. [celá zpráva]

„Některé služby obsahovaly zranitelnou verzi, proto jsme ihned po oznámení chyby nasadili opravu. Nyní necháváme přegenerovat všechny SSL certifikáty postižených služeb u certifikační autority. Abychom měli jistotu, že data našich uživatelů jsou v bezpečí, uživatelům doporučujeme, aby po přihlášení do své schránky změnili hesla,“ řekl Štefan Šafár, bezpečnostní administrátor společnosti Seznam.cz.

ČBA situaci monitoruje

S ohledem na vážnost celé situace se případem zabývá i Česká bankovní asociace (ČBA). Ta ale podle čtvrtečního vyjádření „neregistruje žádné případy nasvědčující tomu, že by servery českých bank byly jakkoli napadeny nebo že by došlo k úniku informací či přihlašovacích údajů bankovních klientů v souvislosti s bezpečnostní chybou v SSL šifrování“.

„Podle bezpečnostních týmů českých bank v souvislosti s Heartbleed Bugem není bezpečnost hesel do internetového bankovnictví nijak ohrožena,“ uvedli zástupci ČBA.

Chyba takového rozsahu se dosud nikdy neobjevila.

Přestože je již k dispozici nová verze knihovny OpenSSL, uživatelé mohou být stále v ohrožení. Útočníkům se totiž citlivá data mohla dostat do rukou ještě před tím, než došlo k opravě bezpečnostní trhliny.

Podle BBC se jedná o jednu nejzávažnějších bezpečnostních trhlin v historii internetu. Chyba, která by v takovém rozsahu vystavila celosvětovou počítačovou síť potenciálním útokům, se totiž zatím nikdy neobjevila.